Sa marche avec les v2